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 Finite Element Analysis of beams 
1 Introduction 

1.1 TP objectives 
In this part, you will get along and discover the FEM (finite element modelling) software COMSOL 

MULTIPHYSICS® v6.1 by simulating a copper beam and a MEMS (micro-electro-mechanical 

system) thermal actuator that you will fabricate in the cleanroom.  

1.2 Introduction of COMSOL MULTIPHYSICS 
The basic steps of simulating in COMSOL include: 

• Definition of the geometry model. The COMSOL provides 3D, 2D symmetric, 2D, 1D

symmetric, 1D, and 0D models. The appropriate choice of dimension can simplify the

calculation while remaining accuracy.

You can draw your model with geometry elements provided in the software, or import your

model from other CAD (computer assistant designing) software such as SOLIDWORKS or

3DSMAX. (The importing procedure is not included in this guideline. If you are interested,

you can find guidelines in Analyze Your SOLIDWORKS® Designs Using COMSOL Multiphysics®)

• Set parameters and materials for your model. For the ease of parameter sweeping, you can

define variables for some of your parameters both in geometry and physics.

To complete a model, you should also declare the material mostly. You can choose the pre-

defined materials with essential properties for the physics in the material library of COMSOL,

or define your own material by filling in the blanks of parameters required by physics.

• Definition of physical model. In the COMSOL, you can work with only one or several different

physical fields, including mechanical, electrical, thermal, and others that you can imagine.

The couple of different physical fields are also done by COMSOL. To well describe the model,

you need to set initial physical status, physical models, and excitations. It’s the most

important but also the trickiest work. You must be experienced to construct a suitable model

for calculation.

• Setting of study steps. The COMSOL provide you with not only basic study such as stationary,

time dependent, and frequency domain, but also advanced ones such as eigenfrequency. You

can choose what you need, and set sweeping parameters if you want.

• Click “Calculate” button to just start the calculation!

• Results plotting and exporting. Basically, after calculation, you can get every parameter that

you care about from the results. The COMSOL provide you with all kinds of plots to show

results. Choose what you believe is the best way to show your results, and check it in the

software. If you want to export your results for further evaluation, it is also easy for the

COMSOL.

1.3 Steps 
In this practical session, you will have 3 models to simulate, and 1 experiment to do. The first 

simulation tells you the static deflection of a macro copper beam under the effect of a certain 

force. The second simulation gives you the resonance frequencies. After these two simulations, you 

will have an experiment of the copper beam the same as your simulation model, to compare the 

results between the simulation and the experiment. 

https://www.epfl.ch/en/
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All the steps above are the preparation for the final step, by getting yourself familiar with the 

simulation and COMSOL software. The final step is to simulate one of the fabricated MEMS beams. 

The simulation of your own design is highly recommended. The simulation results then will help you 

with the designing and the test of the MEMS beam. 

2 Preparation 
During this preparation, you will perform a theoretical prediction of the behaviour of the macro 

copper beam that you will study during the session.  

The theoretical prediction, is to let you perform calculations on a simplified model, with reasonable 

assumptions. Making theoretical predictions is essential for assessing the validity and performance of 

the model used during the simulation. You will also have a rough idea of how the parameters during 

the designing influence the performance. 

Apart from the theoretical calculation of the copper beam, to perform the simulation on your MEMS 

cantilever, please bring the calculation about the inertia moment, spring constant, and 

eigenfrequencies you made previously to the session. 

2.1 Structure and parameters 
Both the copper beam and the MEMS cantilever are embedded and fixed at 𝑥 = 0. For the copper 

beam, a vertical force of 𝐹 = 50𝑚𝑁 is dynamically applied at 𝑥 = 𝑙, which 𝑙 is the length of the 

beam. 

The MEMS beam is composed of a SiO2 layer and a Cr track on top. The cross section of the MEMS 

beam is shown in the figure below. 

The beam dimensions and characteristics are as follows. These numbers are used only in the 

preparation. In the TP session, please use the number you measured (for the copper beam) or 

designed (for the MEMS beam). 

Copper beam MEMS beam 

Beam length 𝑙 𝑙 = 180𝑚𝑚 𝑙 = 500𝜇𝑚 

Beam height ℎ ℎ = 1𝑚𝑚 
ℎ𝑆𝑖𝑂2 = 1.5𝜇𝑚

ℎ𝐶𝑟 = 0.5𝜇𝑚 

Beam width 𝑤 𝑤 = 20𝑚𝑚 
𝑤𝑆𝑖𝑂2 = 80𝜇𝑚

𝑤𝐶𝑟 = 2 × 20𝜇𝑚 

Young’s modulus 𝐸 𝐸 = 110𝐺𝑃𝑎 𝐸𝑆𝑖𝑂2 = 70𝐺𝑃𝑎

https://www.epfl.ch/en/
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𝐸𝐶𝑟 = 140𝐺𝑃𝑎 

Density 𝜌 𝜌 = 8.7𝑔/𝑐𝑚3 
𝜌𝑆𝑖𝑂2 = 2.2𝑔/𝑐𝑚3

𝜌𝐶𝑟 = 7.15𝑔/𝑐𝑚3

2.2 Questions for preparation 
Answer these questions before the TP session. The TA will check your answers before the session. 

2.2.1 Question 1 
Give the deflection 𝑦𝑚𝑎𝑥 of the copper beam with a force 𝐹 = 50𝑚𝑁 applied to its end (static 

deflection; neglect gravity). You can use as reference https://mechanicalc.com/reference/beam-

analysis.  

2.2.2 Question 2 
Plot (with any software that you are familiar with) the deflection 𝑦(𝑥) of the copper beam. You can 

compare this with the simulation result. 

2.2.3 Question 3 
Calculate inertia moment, spring constant and then the equation for the eigenfrequencies 

(resonance frequency) and compute them for the copper beam. Explain and justify approximations 

you did. 

3 Questions during session 
The following are the questions you need to answer in your report. These questions are the ones that 

you need to consider during your practical course. The other questions related to data processing 

and analysis can be found in the file Topic2-373_report_guidelines.pdf. Please don’t forget to answer 

all the questions in your report. 

3.1 Copper beam 

3.1.1 Static analysis 

• Plot the deflection of the beam as simulated in COMSOL.

3.1.2 Frequency response 

• Plot the measured and simulated frequency response from 10Hz – 100Hz in the same graph.

What can you find from the value of the resonance frequency and amplitude at resonance?

Note: concentrate the measurements around the resonant frequencies.

3.2 MEMS beam 
• Sketch the graphs of the mechanical deflection and temperature of the end point in z at

frequencies 1Hz and 100Hz. Customize the stepping time accordingly to the frequency.

Comment on the results and predict behaviour at 10kHz.

• Determine the eigenfrequency of the system and report corresponding shapes with

screenshots.
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4 Copper beam 

4.1 Simulations 
You may see some minor interface changes because the description corresponds to version 6.1. 

4.1.1 Static analysis 
In this part, you will construct a 3D model of a copper beam, and apply a vertical force on its end 

point. By simulation, you will know the displacement of the copper beam, and research on the 

relationship between stress and strain. 

❖ From the File menu, choose New

❖ NEW

In the New window, click Model Wizard

❖ MODEL WIZARD

➢ In the Model Wizard window, click 3D

➢ In the Select Physics tree, select Structural Mechanics > Solid Mechanics (solid)

➢ Click add

➢ Click Study

➢ In the Select Study tree, select General Studies > Stationary

➢ Click Done

❖ GEOMETRY 1

➢ Click Model Builder > Geometry 1

➢ In the Settings window for Geometry 1, locate the Units section.

➢ Find the Length unit sub selection, and choose mm.

Block 1 (blk1) 

➢ In the Geometry toolbar, click Primitives > Block.

➢ In the Settings window for Block 1, locate the Size and Shape section.

➢ In the Width, Depth, and Height text fields, type the copper beam dimension.

➢ In the Geometry toolbar, click Build All.

❖ MATERIALS

Copper (mat1) 

➢ In the Materials toolbar, click Add Material

MICRO – 373 Advanced microfabrication practicals | COMSOL Simulation LMIS1  
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➢ In the Add Material window, select Built-in > Copper

➢ Click Add to Component

➢ In the Settings window for Copper, make sure that the beam is chosen in the Geometric

Entity Selection

➢ Close the Add Material window

❖ SOLID MECHANICS (SOLID)

➢ Left-click the Solid Mechanics (solid) in the Model Builder

Fixed Constraint 1 

➢ In the Physics toolbar, select Boundaries > Fixed Constraint

➢ In the Settings window for Fixed Constraint 1, locate Boundary Selection

➢ In the Graphics window, choose one surface at the end of the beam by left-click

Boundary Load 1 

➢ In the Physics toolbar, select Boundaries > Boundary Load

➢ In the Settings window for Boundary Load 1, locate Boundary Selection

➢ In the Graphics window, choose the surface at another end of the beam by left-click

➢ In the Load type selection list of the Force tab, choose Total force

MICRO – 373 Advanced microfabrication practicals | COMSOL Simulation LMIS1  
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➢ In the z text field of 𝐅𝐭𝐨𝐭, enter the value of the force and the unit in between [] (notice the

direction of the force)

❖ MESH 1

➢ In the Settings window of Mesh 1, check that Physics-controlled mesh is chosen in Sequency

Type selection list, and Normal is chosen in Physics-Controlled Mesh > Element size

selection list

➢ Click Build All

❖ STUDY 1

➢ Choose Study 1 in the Model Builder, click Compute in the Settings window

❖ RESULTS

Cut Line 3D 1 

➢ In the Results toolbar, click Dataset > Cut Line 3D

➢ In the Settings window of Cut Line 3D 1, locate the Line Data section

➢ Enter the coordinates of two points to create a cut line along the beam in the X, Y, and Z text

fields of Pont 1 and Point 2. For example, Point 1 (0, Width / 2 [mm], 0) and Point 2 (Length

[mm], Width / 2 [mm], 0), replace Width and Length by the values

MICRO – 373 Advanced microfabrication practicals | COMSOL Simulation LMIS1  
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1D Plot Group 2 

➢ In the Results toolbar, click Plot Group > 1D Plot Group

➢ In the 1D Plot Group 2 toolbar, click Add Plot > Line Graph

➢ In the Settings window of Line Graph 1, locate the Data > Dataset choosing list, and select

Cut Line 3D 1

➢ Locate the y-Axis Data > Expression text field, enter (or choose from Replace Expression)

solid.disp

➢ Click Plot

Export 

➢ In the Results toolbar, click Export > Data > Plot

➢ In the Settings window of Plot 1, locate Plot > Plot group choosing list, and choose 1D Plot

Group 2

➢ Locate Output > Filename, select the place and filename with Browse for your exported file

➢ Click Export

➢ Use the exported data to answer the question in section 3.1.1

4.1.2 Frequency Response Analysis 
In this part, you will construct a 2D model of the same copper beam as we simulated in the static 

analysis. The using of 2D model is to simplify the calculations. You will apply a harmonic force with 

frequency excitation between 10Hz and 1kHz to determine the frequency response of this copper 

beam, to find a rough range of the eigenfrequency of it. 

❖ From the File menu, choose New

❖ NEW

In the New window, click Model Wizard

❖ MODEL WIZARD

➢ In the Model Wizard window, click 3D

➢ In the Select Physics tree, select Structural Mechanics > Solid Mechanics (solid)

➢ Click add

➢ Click Study

➢ In the Select Study tree, select General Studies > Frequency Domain

➢ Click Done

❖ GEOMETRY 1

MICRO – 373 Advanced microfabrication practicals | COMSOL Simulation LMIS1  
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➢ Click Model Builder > Geometry 1

➢ In the Settings window for Geometry 1, locate the Units section.

➢ Find the Length unit sub selection, and choose mm.

Rectangle 1 (r1) 

➢ In the Geometry toolbar, click Primitives > Rectangle

➢ In the Settings window of Rectangle 1, locate the sub-section Size and Shape

➢ In the Width and Height text fields, enter the length and height of the copper beam

➢ In the Geometry toolbar, click Build All

❖ MATERIALS

Copper (mat1) 

➢ In the Materials toolbar, click Add Material

➢ In the Add Material window, select Built-in > Copper

➢ Click Add to Component

➢ In the Settings window for Copper, make sure that the beam is chosen in the Geometric

Entity Selection

➢ Close the Add Material window
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❖ SOLID MECHANICS (SOLID)

➢ Left-click the Solid Mechanics (solid) in the Model Builder

➢ In the Settings window of Solid Mechanics, locate Thickness

➢ In the d text field, enter the width of the copper beam (be careful to the unit)

Damping 1 

➢ Right click Linear Elastic Material 1, choose Damping

➢ In the Settings window, locate the Damping Settings section

➢ In the Mass damping parameter text field, enter 4.5

➢ In the Stiffness damping parameter text field, enter 1e-8

Fixed Constraint 1 

➢ In the Physics toolbar, choose Boundary > Boundaries > Fixed Constraint

➢ In the Settings window for Fixed Constraint 1, locate Boundary Selection

➢ In the Graphics window, choose the boundary of one end of the beam by left-click
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Boundary Load 1 

➢ In the Physics toolbar, choose Boundary > Boundaries > Boundary Load

➢ In the Settings window for Boundary Load 1, locate Boundary Selection

➢ In the Graphics window, choose the boundary of another end of the beam by left-click

➢ Locate the Force, choose Total force in the Load type selection list

➢ In the y text field of 𝐅𝐭𝐨𝐭, enter the value of the force and unit (notice the direction)

❖ MESH 1

➢ In the Settings window of Mesh 1, check that Physics-controlled mesh is chosen in Sequency

Type selection list, and Normal is chosen in Physics-Controlled Mesh > Element size

selection list

➢ Click Build All

MICRO – 373 Advanced microfabrication practicals | COMSOL Simulation LMIS1  
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❖ STUDY 1

➢ Click Study 1 > Step 1: Frequency Domain in the Model Builder

➢ In the Settings window, locate Study Settings

➢ In the Frequencies text field, enter range(10, 10, 1000)

➢ Click Compute

❖ RESULTS

1D Plot Graph 2 

➢ In the Results toolbar, click Plot Group > 1D Plot Group

➢ In the 1D Plot Group 2 toolbar, click Point Graph

➢ In the Settings window of Point Graph 1, locate Selection

➢ In the Graphics window, choose one point at the free end of the beam by left click

➢ In the y-Axis Data > Expression text field, enter (or choose in the Replace Expression)

solid.disp

➢ Click Plot

➢ To change the scale to logarithm, click 1D Plot Group 2, locate Axis in the Settings window,

and click to activate x-axis log scale

MICRO – 373 Advanced microfabrication practicals | COMSOL Simulation LMIS1  
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Export 

➢ In the Results toolbar, click Export > Data > Plot

➢ In the Settings window of Plot 1, locate Plot > Plot group choosing list, and choose 1D Plot

Group 2

➢ Locate Output > Filename, select the place and filename with Browse for your exported file

➢ Click Export

➢ Use the exported data to answer the question in section 3.1.2

4.2 Experiment 
The goal of the experiment here is to retrace the frequency response of the copper beam subjected 

to a magnetic AC excitation between 1Hz and 100Hz. Refer to the numerical simulation to identify 

the frequency range of interest and make a number of measurements sufficient to draw a response. 

The reflection of a laser off the beam onto the wall allows for the measurement of the deflection. 

The trace of the laser is measured on a graph paper taped to the wall. 

Use the obtained data to answer the question in section 3.1.2. 

MICRO – 373 Advanced microfabrication practicals | COMSOL Simulation LMIS1  
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5 MEMS Beam 

In this section, you will simulate on the MEMS thermal bimorph cantilever you will 

fabricate / fabricated in the cleanroom session. You will do a time dependent simulation and 

a eigenfrequency simulation on this model.  

❖ From the File menu, choose New.

❖ NEW

In the New window, click Model Wizard

❖ MODEL WIZARD

➢ In the Model Wizard window, click 3D.

➢ In the Select Physics tree, select Structural Mechanics > Thermal-Structure Interaction >

Joule Heating and Thermal Expansion

➢ Click add

➢ Click Study

➢ In the Select Study tree, select General Studies > Time Dependent

➢ Click Done

❖ GEOMETRY 1

➢ Click Model Builder > Geometry 1

➢ In the Settings window for Geometry 1, locate the Units section.

➢ Find the Length unit sub selection, and choose µm.

Block 1 (blk 1) 

➢ In the Geometry toolbar, click Primitives > Block

➢ In the Settings window of Block 1, locate Size and Shape

➢ In the Width, Depth, and Height text fields, enter dimensions of the beam’s SiO2 part

➢ Locate Axis, choose Cartesian in the Axis type selection list

➢ In the z text field of Axis, enter -1, which turns reverts the axis so that the SiO2 top surface is

placed at z=0

➢ Click Build Selected

Work Plane 1 (wp1) 

➢ In the Geometry toolbar, click Work Plane > Work Plane

MICRO – 373 Advanced microfabrication practicals | COMSOL Simulation LMIS1  
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Polygon 1 (pol1) 

➢ Click Work Plane 1 > Plane Geometry

➢ In the Sketch toolbar, click Polygon, Circular Arc, Interpolation Curve, or any other tools, to

draw the trace of the metal line on the beam, finishing by right-click and choose Finish xxx

Thicken 1 (thi1) 

➢ In the Work Plane toolbar, choose Operations > Conversions > Thicken

➢ In the Settings window of the Thicken 1, locate the Input > Input entities

➢ In the Graphics window, choose the metal trace you drew by left-click

➢ Locate Options, enter the width of the metal trace in the Total thickness text field

➢ Click Build Selected

Extrude 1 (ext1) 

➢ Left-click Work Plane 1 (wp1)

➢ In the Geometry toolbar, click Operations > Extrude

➢ In the Settings window of Extrude 1, Locate General

➢ In the Work plane choosing list, choose Work Plane 1 (wp1)

➢ Locate Distances, enter the thickness of metal trace (0.5µm) in the Distances text field

➢ Click Build All
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❖ MATERIALS

➢ In the Materials toolbar, click Add Material

Cr – Chromium (mat1) 

➢ In the Add Material window, choose MEMS > Metals > Cr – Chromium, and click Add to

Component

➢ In the Settings window of Cr – Chromium (mat1), locate Material Contents

➢ Enter 1 in the text field of Value of Relative permittivity

➢ Enter 6.6e5[S/m] in the text field of Value of Electrical conductivity (thin film conductivity

rather than bulk conductivity, measured my CMi staff after deposition by evaporation)

➢ Locate Geometric Entity Selection > Selection

➢ In the Graphics window, choose only the metal trace by left-click

SiO2 – Silicon oxide (mat2) 

➢ In the Add Material window, choose MEMS > Insulators > SiO2 – Silicon oxide, and click Add

to Component

➢ In the Settings window of SiO2 – Silicon oxide (mat2), locate Geometric Entity Selection >

Selection

➢ In the Graphics window, choose the SiO2 cantilever by left-click

➢ Close Add Material window

❖ GLOBAL DEFINITIONS

➢ Click Model Builder > Global Definitions > Parameters 1

➢ Fill in the table with the following parameters (the Value column will be filled automatically)

Name Expression Description 

f_exc 1[Hz] Excitation frequency 

V_exc 0.5[V] Max excitation voltage 

h_air 10[W/(m^2*K)] Air convection constant 

T_init 300[K] Initial temperature 

❖ SOLID MECHANICS (SOLID)

➢ Left-click Model Builder > Solid Mechanics (solid)
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Fixed Constraint 1 

➢ In the Physics toolbar, click Boundary > Boundaries > Fixed Constraint

➢ In the Settings window of Fixed Constraint 1, locate Boundary Selection

➢ In the Graphics window, choose all the surfaces that are fixed (including SiO2 cantilever and

Cr trace)

Initial Stress and Strain 1 

➢ Click Model Builder > Solid Mechanics (solid) > Linear Elastic Material 1

➢ In the Physics tool bar, choose Contextual > Attributes > Initial Stress and Strain

➢ In the Settings window of Initial Stress and Strain 1, locate Domain Selection

➢ In the Graphics window, choose the domain of Cr trace

➢ In the Settings window of Initial Stress and Strain 1, locate Initial Stress and Strain

➢ Enter 325[MPa] along the diagonal of the text fields of Initial stress

Initial Stress and Strain 2 

➢ Click Model Builder > Solid Mechanics (solid) > Linear Elastic Material 1

➢ In the Physics tool bar, choose Contextual > Attributes > Initial Stress and Strain

➢ In the Settings window of Initial Stress and Strain 2, locate Domain Selection
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➢ In the Graphics window, choose the domain of SiO2 cantilever

➢ In the Settings window of Initial Stress and Strain 2, locate Initial Stress and Strain

➢ Enter -332[MPa] along the diagonal of the text fields of Initial stress

❖ ELECTRIC CURRENTS (EC)

➢ Left-click Model Builder > Electric Currents (ec)

Ground 1 

➢ In the Physics toolbar, choose Boundary > Boundaries > Ground

➢ In the Settings window of Ground 1, locate Boundary Selection

➢ In the Graphics window, choose one surface at the end of the Cr trace by left-click

Electric Potential 1 

➢ In the Physics toolbar, choose Boundary > Boundaries > Electric Potential

➢ In the Settings window of Electric Potential 1, locate Boundary Selection

➢ In the Graphics window, choose another surface at the end of the Cr trace by left-click

➢ In the Settings window of Electric Potential 1, locate Electric Potential

➢ In the Electric potential text field, enter V_exc*sin(2*pi*f_exc*t)

MICRO – 373 Advanced microfabrication practicals | COMSOL Simulation LMIS1  
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❖ HEAT TRANSFER IN SOLIDS (HT)

➢ Left-click Model Builder > Heat Transfer in Solids (ht)

Temperature 1 

➢ In the Physics toolbar, choose Boundary > Boundaries > Temperature

➢ In the Settings window of Temperature 1, locate Boundary Selection

➢ In the Graphics window, choose all the surfaces that are fixed by left-click

➢ In the Settings window, locate Temperature

➢ In the Temperature text field, enter T_init

Heat Flux 1 

➢ In the Physics toolbar, choose Boundary > Boundaries > Heat Flux

➢ In the Settings window of Heat Flux 1, locate Boundary Selection

➢ In the Selection list, choose All boundaries

➢ In the Graphics window, deselect the 3 surfaces that are fixed by left-click

➢ In the Settings window of Heat Flux 1, locate Material Type

➢ Choose From material in the Material type selection list

➢ In the Settings window of Heat Flux 1, locate Heat Flux

➢ Choose Convective heat flux in the Flux type selection list
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➢ In the Heat transfer coefficient text field, enter h_air

➢ In the External temperature text field, enter T_init

❖ MESH 1

➢ Left-click Model Builder > Mesh 1

Free Triangular 1 

➢ In the Mesh toolbar, choose Generators > Boundary > Free Triangular

➢ In the Settings window of Free Triangular 1, locate Geometric Entity Selection

➢ In the Graphics window, choose the bottom surface of the Cr trace

➢ In the Mesh toolbar, choose Attributes > Normal > Extremely Fine

Swept 1 

➢ In the Mesh toolbar, choose Generators > Swept

➢ In the Settings window of Swept 1, locate Domain Selection

➢ In the Geometric entity level choosing list, choose Domain

➢ In the Graphics window, choose the Cr trace domain

➢ In the Mesh toolbar, choose Attributes > Distribution

➢ In the Settings window of Swept 1 > Distribution 1, locate Distribution

➢ Choose Fixed number of elements in the Distribution type choosing list

➢ Enter 2 in the Number of elements text field

Free Triangular 2 

➢ In the Mesh toolbar, choose Generators > Boundary > Free Triangular

➢ In the Settings window of Free Triangular 2, locate Geometric Entity Selection

➢ In the Graphics window, choose all the top surfaces of the SiO2 cantilever (multiple surfaces)

➢ In the Mesh toolbar, choose Attributes > Normal > Extremely Fine

Swept 1 

➢ In the Mesh toolbar, choose Generators > Swept

➢ In the Settings window of Swept 2, locate Domain Selection

➢ In the Geometric entity level choosing list, choose Domain

➢ In the Graphics window, choose the SiO2 cantilever domain

➢ In the Mesh toolbar, choose Attributes > Distribution
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➢ In the Settings window of Swept 2 > Distribution 1, locate Distribution

➢ Choose Fixed number of elements in the Distribution type choosing list

➢ Enter 2 in the Number of elements text field

➢ Click Build All

❖ STUDY 1 (TIME DEPENT)

➢ Left-click Model Builder > Study 1 > Step 1: Time Dependent

➢ In the Settings window of Step 1: Time Dependent, locate Study Settings

➢ In the Output times text field, enter text according to the chart below

Frequency f_exc Output times 

1Hz range(0,0.01/f_exc,2/f_exc) 

100Hz range(0,0.05/f_exc,3/f_exc) 

➢ Click Compute

➢ To change the simulation frequency, remember to change the f_exc in Global definitions >

parameters and Step 1: Time Dependent > Output times

❖ RESULTS (TIME DEPENT)

➢ In the Results toolbar, choose Dataset > Cut Point 3D

➢ In the Settings window of Cut Point 3D 1, locate Point Data
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➢ In the x, y, and z text fields, enter the coordinates of the point in the middle of the free end

part, for example, (0, 40[um], 0)

➢ Click Plot to confirm the position of this point

1D Plot Group 6 

➢ In the Results toolbar, choose Plot Group > 1D Plot Group

➢ In the 1D Plot Group 6 toolbar, choose Add Plot > Point Graph

➢ In the Settings window of Point Graph 1, locate Data

➢ Choose Cut Point 3D 1 in the Dataset choosing list

➢ In the Settings window of Point Graph 1, locate y-Axis Data

➢ Enter solid.disp in the Expression text field, or choose from the Replace Expression on the

top-right of this section

➢ Click plot

➢ Enter T in the Expression text field, and click plot again for the temperature change

Export 

➢ In the Results toolbar, click Export > Data > Plot

➢ In the Settings window of Plot 1, locate Plot > Plot group choosing list, and choose 1D Plot

Group 6

➢ Locate Output > Filename, select the place and filename with Browse for your exported file

➢ Click Export

➢ After change the 1D Plot Group 6 > Expression to T, or change the frequency, repeat the

upper steps again to export another set of data

➢ Use the exported data (2 frequencies, for both temperature and mechanical displacement)

to answer the question in section 3.2

❖ STUDY 1 (EIGENFREQUENCY)

➢ Right-click on the Step 1: Time Dependent, choose Disable

➢ Right-click on the Study 1, choose Study Steps > Eigenfrequency > Eigenfrequency

➢ In the Settings window of the Step 2: Eigenfrequency, locate Study Settings

➢ Click to activate the Desired number of eigenfrequencies, and enter 3 in the following text

field

➢ In the Settings window of the Step 2: Eigenfrequency, locate Physics and Variables Selection
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➢ Deselect Heat Transfer in Solids (ht), Electric Currents (ec), and Electromagnetic Heating 1

(emh1). Leave only Solid Mechanics (solid) and Thermal Expansion 1 (te1)

➢ Click Compute

❖ RESULTS (EIGENFREQUENCY)

➢ Left-click Model Builder > Results > Stress (solid)

➢ In the Settings window of the Stress (solid), locate Data

➢ Choose different frequency in the Eigenfrequency choosing list

➢ Click Plot

➢ In the Graphics window, find the camera icon Image Snapshot to take a snapshot

➢ Record both the eigenfrequency and the shape of cantilever with snapshot, and use them to

answer the question in the section 3.2
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6 Report guidelines 
After the COMSOL Simulation 4-hour session, you need to submit a report in the required time. 

Here are the instructions when you are writing your report. 

6.1 Timeline 
Your report must be submitted on Moodle latest one week after the practical session. You can make 

multiple submission, only the latest submitted file will be considered for grading. Please submit only 

one report per group entitled: “GRx_report_LastName1_LastName2_LastName3.pdf”. This report is 

independent of the other sessions’ report. 

If you feel your answers on some questions are wrong, you are encouraged to seek advice from the 

TA. If this is the case, submit a complete report on Moodle and contact your TA with defined 

questions; still within one week after the practical session. Given you did all this, your TA will give 

you some additional time to improve your initial report. 

6.2 Contents 

6.2.1 Introduction 
Explain how this practical session fits in the overall course (theory, simulation, fabrication, 

characterization). What is the role of simulation in a scientific framework? When do you normally do 

it (before / after fabrication / experimentation)? 

Give a quick introduction to finite element analysis. List the various part of this practical session. 

State what kind of simulation we perform for the copper beam and MEMS actuator respectively. 

6.2.2 Theoretical estimate 
Add your answers to the preparation questions in section 2.2 here. 

6.2.3 Results 
For each section, describe the modelling / experimental work you performed with the help of the 

answers to the questions in the section 3. Your discussion should at least include answer to the 

questions below. 

❖ Copper beam

➢ Q1. Briefly describe the stationary study conducted. Plot the simulated deflection of the

copper beam. Compare this result to the theoretical result from the preparation questions.

How much does it deviate from theory?

➢ Q2. Introduce the experiment you conducted with the copper beam. Describe your set up:

how the beam was clamped, what electronics, light source and mechanical clamp you used.

➢ Q3. Explain how the beam was actuated. Discuss whether copper on its own should

experience a force in a magnetic field.

➢ Q4. What way of measuring the beam deflection did you use? Is it a direct measurement?

What oscillation frequency do you expect with respect to the stimulation applied?

➢ Q5. Briefly describe the frequency response study. Plot the experimental and simulated

response in the amplitude of the copper beam on the same graph. Comment on the two

units of the data plotted. Are they comparable (in amplitude) and why? Discuss about the

agreement between the theory, experiment and simulation. What is your opinion the main

cause of discrepancy?

❖ MEMS actuators

➢ Q6. Briefly describe the microfabrication process of the actuators. Why are they bent at rest?

How do we account for this bending in the simulation?
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➢ Q7. Explain the actuators functioning principle: why do they oscillate under an AC current

and how is this originating from difference of thermal expansion coefficient? What equation

rules the heating of the actuators? What frequency of oscillation do you expect with respect

to the stimulation frequency?

➢ Q8. Briefly describe the time dependent study you performed. Plot the simulated

displacement and temperature of the actuator on the same graph (use two y-axis). Make a

separate graph for the stimulation at 1Hz and 100Hz.

➢ Q9. Explain how and why the result of the 100Hz stimulation are different. What behaviour

would you expect at 10kHz (average displacement / temperature, oscillations amplitude)?

Remember the equation describing the heating of the actuator from Q7. Is it dependent on

the stimulation frequency?

➢ Q10. In order to complete a finite element model simulation faster, what parameter can we

change and what is the trade-off? Which one did you influence in the MEMS actuator

simulation? Is convergence of the solver always guaranteed?

➢ Q11. Report the eigenfrequencies of the actuator. Given the trend of the oscillations

amplitude for increasing frequencies, do you need to prepare a microscope to observe the

actuators during the future characterization of the actuator session?

6.2.4 Conclusion 
Summarize your work in this session. What result is the most important for the continuation of the 

course? 
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